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NOTICES 
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Revision date July 2024 

 

 

Legal notices 

 
ALL PRODUCT(S) AND SERVICES DESCRIBED HEREIN ARE INTENDED FOR RESEARCH USE ONLY, AND NOT FOR USE IN DIAGNOSTIC OR 

TREATMENT PROCEDURES OR FOR ANY OTHER USE.  

 

FAILURE TO COMPLETELY READ AND EXPLICITLY FOLLOW ALL OF THE INSTRUCTIONS CONTAINED HEREIN MAY RESULT IN DAMAGE TO THE 

PRODUCT(S), INJURY TO PERSONS, INCLUDING TO USERS OR OTHERS, AND DAMAGE TO OTHER PROPERTY. VIZGEN, INC. (“Vizgen”) DOES 
NOT ASSUME ANY LIABILITY ARISING OUT OF THE IMPROPER USE OF THE PRODUCT(S) DESCRIBED HEREIN (INCLUDING PARTS THEREOF OR 

SOFTWARE) OR ANY USE OF SUCH PRODUCT(S) OUTSIDE THE SCOPE OF THE EXPRESS WRITTEN LICENSES OR PERMISSIONS GRANTED BY 

VIZGEN IN CONNECTION WITH CUSTOMER’S ACQUISITION OF SUCH PRODUCT(S).  

 

Nothing contained herein shall constitute any warranty, express or implied, as to the performance of any product(s) described herein. Any 

and all warranties applicable to any product(s) and software are set forth in the applicable terms and conditions of sale accompanying the 

purchase of such product(s). Vizgen provides no warranty and hereby disclaims any and all warranties as to the use of any third-party 

product(s) or protocols described herein. The use of product(s) described herein is subject to certain restrictions as set forth in the 

applicable terms and conditions of sale accompanying the purchase of such product(s).  

 

Updates to product(s) and software may be required to enable customers to use product(s). If you fail to update the product(s) or software 

when provided by Vizgen, any warranty thereon shall immediately terminate. In the event of a product failure resulting from an update, 

such failed product will be subject to the warranty set forth in the terms and conditions agreed to in connection with the purchase of such 

product, if any, only if such product is covered by such warranty at the time of such failure. Vizgen is not required to repair, replace, or take 

any other remedial action with respect to any product not covered under such warranty.  

 

Vizgen®,MERSCOPE® and MERSCOPE UltraTM are trademarks of Vizgen. All rights in the trademarks, service marks, trade dress, logos and 

copyrights are owned by Vizgen, Inc. and fully reserved. All other brands and names contained herein are the property of their respective 

owners.  

 

This document and its contents are proprietary to Vizgen, Inc. and its affiliates, and are intended solely for the contractual use of its 

customer in connection with the use of the product(s) described herein and for no other purpose. This document and its contents shall not 

be used or distributed for any other purpose and/or otherwise communicated, disclosed, or reproduced in any way without the prior 

written consent of Vizgen. Vizgen does not convey any license under any patent, trademark, copyright, or common-law rights, nor similar 

rights of any third parties, by this document. The instructions in this document must be strictly and explicitly followed by qualified and 

properly trained personnel in order to ensure the proper and safe use of the product(s) described herein. All of the contents of this 

document must be fully read and understood prior to using such product(s).  

 

© 2024 Vizgen, Inc. All rights reserved.  



MERSCOPE
® 

Vizualizer Software User Guide 

91600100 • Rev D TABLE OF CONTENTS Page 3 of 53 

 

 

 

SUPPORT 

 

 
Contact information 

support@vizgen.com 

61 Moulton Street 

West Cambridge Science Park Cambridge, 

MA 02138 

USA 

 

 

Other Vizgen references are available online at https://vizgen.com/ 

mailto:support@vizgen.com
https://vizgen.com/
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VERSION CHANGE NOTES 

Summary of substantive changes from Rev C to Rev D 
 

Brief description of change Page(s) 

Updated to accommodate compatibility with MERSCOPE Ultra Software (v234) 

and output file (.VZG2). 

Throughout 
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INTRODUCTION 

 
MERFISH Technology 

Multiplexed error-robust fluorescence in situ hybridization (MERFISH) is a spatially resolved single-

cell transcriptome profiling technology. MERFISH combines the power of single-cell transcriptomics 

with spatial biology by directly visualizing and counting RNA transcripts from 100s to >10,000 genes 

in cells or tissue sections. 

MERFISH advances the power of single-molecule fluorescence in situ hybridization (smFISH) – the gold 

standard of RNA quantification – with error robust barcoding, combinatorial labeling, and sequential 

imaging to greatly expand the multiplexing capacity. MERFISH enables researchers to map the 

molecular, cellular, and functional composition of biological systems with spatial context. 

 

The Vizgen MERSCOPE® and MERSCOPE Ultra™ Platform Solutions 

The Vizgen MERSCOPE Platform Solution is comprised of the Vizgen Gene Panel Design Portal, 

MERSCOPE reagent kits, the MERSCOPE Instrument, the MERSCOPE Analysis Computer, and the 

MERSCOPE Vizualizer software to streamline the acquisition of high quality MERFISH data and data 

interpretation. 

The MERSCOPE Ultra Platform is Vizgen's latest generation spatial imaging platform. MERSCOPE Ultra 

offers the same high-quality, high-resolution MERFISH data as MERSCOPE but on a larger scale with an 

expansive imaging area up to 3.0cm2. MERSCOPE Ultra is comprised of the MERSCOPE Ultra 

Instrument and MERSCOPE Ultra Analysis PC and its workflow is also supported by the Vizgen Gene 

Panel Design Portal and MERSCOPE Vizualizer software.   

Reagent kits facilitate sample preparation. The automated MERSCOPE and MERSCOPE Ultra 

Instruments integrate high-resolution imaging and fluidics to automatically acquire a full MERFISH 

dataset. The MERSCOPE Vizualizer software automates image processing and offers interactive 

visualization tools to explore MERFISH data. 
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The MERSCOPE Workflow 

The MERSCOPE Workflow begins with either designing a MERSCOPE Custom Gene Panel or ordering a 

MERSCOPE Predesigned Gene Panel. 

Design a custom gene panel. The intuitive Vizgen Gene Panel Design Portal makes recommendations 

on your custom gene panel for optimal performance in a MERFISH measurement. For example, the 

portal highlights genes that might cause optical crowding or cannot be accurately targeted. Vizgen is 

currently offering custom gene panels for up to 140 genes, up to 300 genes, up to 500 genes, and up 

to 1000 genes. 

Order your MERSCOPE Gene Panel. MERSCOPE Custom Gene Panels and MERSCOPE Predesigned 

Gene Panels are delivered in a ready-to-use format. Once the gene panel is finalized, users will be able 

to download their panel-specific MERSCOPE Codebook to the MERSCOPE Instrument. 

Prepare your sample. The Vizgen sample preparation user guides take users through each step of the 

MERSCOPE sample preparation process. 

Load and run the MERSCOPE Instrument. The MERSCOPE Slide is assembled into the MERSCOPE Flow 

Chamber and then loaded into the instrument along with a MERSCOPE Imaging Cartridge. Users 

define regions of interest on the MERSCOPE Slide and initiate the fully automated instrument run. 

Data Processing and Visualization. The MERSCOPE Instrument Software (in combination with the 

MERSCOPE Analysis Computer) automatically processes the raw images to output spatial genomics 

measurements in a format ready for immediate downstream analysis. The output includes the list of 

all detected transcripts and their spatial locations in three dimensions (CSV files), mosaic images 

(TIFF), experiment metadata (JSON), output from the cell segmentation analysis: transcripts per cell 

matrix (CSV), cell metadata (CSV), cell boundaries (HDF5 [MERSCOPE Instrument Software v231 or  
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earlier] or PARQUET [v232 or later]), and a binary for use with the MERSCOPE Vizualizer software. The 

MERSCOPE Platform Solution includes the MERSCOPE Vizualizer software for visualizing and analyzing 

data. The output files are also compatible with open-source tools for single-cell and spatial analysis. 

Broad Application 

The MERSCOPE Platform Solution has broad application in both fundamental biology and medicine – 

from basic science, to drug discovery, to clinical pathology. Find out more at 

https://vizgen.com/applications/. 

Oncology Immunology Neuroscience Infectious Disease Developmental Biology & 

Regenerative Medicine 

https://vizgen.com/applications/
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VIZUALIZER SOFTWARE USER INTERFACE OVERVIEW 

 

 

 

 

 

 

1 Main menu bar 

File Open experiment, recent, import data, export data, save 

experiment, assemble experiment 

Edit Manage image channels and region of interest (ROI) sets, 

save a copy of custom feature set groups 

View Control the visibility of the floating panels surrounding the 

spatial view window 

Help Version information, about Qt (the C++ framework used for 

application development), open the report folder, archive logs 

2 Spatial view window Tissue visualization, view the MERSCOPE Instrument output data 

3 Heatmap A two-dimensional view of cells by gene count data 

4 Spatial features 
Manage the active category, cell groups, and ROIs. Each feature set 

(cells, ROI sets) is addressed individually 

5 Genes View, select, and create gene groups 

 

6 Scatterplot 

Display two-dimensional arrays, such as cells in dimensionality reduced 

gene expression space (e.g., UMAP/tSNE*) or other user- imported two-

dimensional arrays (e.g., cell volume versus transcript 

count) 

7 Details Information on a selected gene, cell, or ROI 

8 Selected items A list of selected cells and ROIs, and create cell and ROI groups 

 
*UMAP, uniform manifold approximation and projection; tSNE, t-distributed stochastic neighbor embedding. 

 

1 

4 2 6 

5 7 

3 
8 
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QUICK START ORIENTATION 

The MERSCOPE Vizualizer software enables interactive visualization and exploration of all components 

of a MERFISH measurement acquired on the MERSCOPE Instrument, including the detected transcripts 

and the segmented cell boundaries overlaid on the underlying images. The MERSCOPE Vizualizer uses 

data in the .VZG format, which is a compressed representation of the MERSCOPE Instrument output 

data optimized for efficient visualization. 

Note: For instruments running control software version 234 and above, the .VZG format has been 

replaced with .VZG2. This new format includes more efficient file packing and stores fewer mosaic tiff 

images for a reduced, more manageable file size. Datasets from .VZG and .VZG2 can be combined in a 

single experiment within Vizualizer Software. 

– The quick start orientation narrative is intended to help users quickly understand basic  functions 

and get started with the MERSCOPE Vizualizer software. Links to more detailed descriptions of 

software operations and additional features are included in the narrative. 

 

Installation 

 Install the MERSCOPE Vizualizer software using the installer executable and follow the installation 

prompts. 

 Installation requires registering your installation with Vizgen. To register, follow the prompts, insert 

an email address, and enter the activation code that is shown on the registration landing page and 

emailed to you as a copy. Vizgen will use the provided email address 

to send notifications about new MERSCOPE Vizualizer software releases. Check Software  Versions 

for any potential incompatibility between experiments assembled in different versions. 

– DO NOT install the MERSCOPE Vizualizer software on the MERSCOPE Instrument or the 

MERSCOPE Analysis Computer. 

 

Create a First Experiment 

 An experiment in the MERSCOPE Vizualizer software is a collection of datasets, where each dataset 

is aROI defined on the MERSCOPE Instrument software 

during data acquisition. An experiment can contain one or more datasets that use the same 

MERSCOPE Gene Panel. 

 A dataset .VZG/.VZG2 file can be found in the merfish_output directory on the Z: drive of the MERSCOPE 

Instrument. Copy the .VZG/.VZG2 file to your computer either over the network or via a USB drive. Open 

the MERSCOPE Vizualizer software and assemble the experiment by selecting File > 

Assemble experiment from the MENU BAR. 

 Enter a name for the new experiment in the Experiment name text field. Click the folder next to 

Select datasets to open a file browser and select the .VZG/.VZG2 file(s) copied from the 

MERSCOPE Instrument. Select an output location and click Build to assemble the experiment. 
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  The MERSCOPE Vizualizer software will unpack the .VZG/copy the .VZG2 file(s) into the specified 

experiment directory. Once the experiment is created, the user interface will populate with the 

experiment data. 

 When creating an experiment from .VZG2 files, users are given the option to “Skip copying datasets” 
to save on disk space. When selected, this feature will create a hard link directly to the source 

.VZG2 file without creating a copy of the data. The hard link appears in the Experiment folder as a 

typical file but is only a pointer to the source data. As such, deleting the source file in its original 

location alone will not free up disk space. Deleting both the source file and hard link will recover 

disk space. When this feature is not selected, the software will duplicate the data from the source 

.VZG2 into the Experiments folder doubling the disk space requirement for the given experiment. 

 

 Initially, the center z-plane of transcripts, cells, and images are displayed in the SPATIAL VIEW  

WINDOW (refer to Spatial Settings for more information on z-planes). All transcripts can be toggled 

on and off in the Spatial Settings menu (the tools icon above the top right of the spatial view 

window) and selecting All in the Z-plane menu for the transcripts layers. Cells and images can also 

be toggled on and off in this menu. All cell polygons can be visualized by selecting ‘All’ in Z-plane 

menu, while for images layer, only active z plane can be selected. 

NOTE:  With .VZG2 files, transcripts from all z planes are represented in a single, stacked image  and 

displayed as “All” always. 

 To quickly visualize the measured expression of each gene, click on the name of a gene in the GENES 

TREE in the genes panel and use the up/down arrow keys to scroll through the list. When a gene is 

highlighted in the genes list, only the highlighted gene is displayed in color (the others are displayed 

gray) in the spatial view window (the transcripts layer must be checked). Press Esc to reset the 

selection. 

– Note that ROIs on the MERSCOPE Instrument are different from ROIs defined in the MERSCOPE 

Vizualizer software in the SPATIAL FEATURES PANEL - REGIONS OF INTEREST. 

 

Generate and Import Custom Cell Type Annotations 

 The MERSCOPE Vizualizer software is able to visualize custom cell type annotations. To generate 

custom cell type annotations and populate the SCATTERPLOT with a UMAP representation of the 

data, the cell by gene matrix can be exported from the MERSCOPE Vizualizer software, loaded into 

custom analysis tools, exported with cell type annotations, and imported back into the MERSCOPE 

Vizualizer software with cell type annotations. 

MERSCOPE Vizualizer exports and imports cell annotations in the AnnData (HDF5), CSV, or PARQUET 

formats. 

 To export an AnnData (.HDF5) file, select File > Export data > Metadata > [feature set] from the 

MENU BAR. Select AnnData data format, navigate to the save location, and click Export. 
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Open Custom Cell Clustering Analysis 

– To execute this process, uploaded files must NOT have a _clustered suffix to the .HDF5 file name 

(an error will occur during Load AnnData). If a file has previously been processed (clustered) and 

the file name changed to remove _clustered, errors may occur during processing. 

 A Vizgen template Jupyter Notebook is hosted on Google CoLab. To cluster the cells in the exported 

AnnData file in the Google CoLab notebook, navigate to https://vizgen.com/merscope-clustering/ 

and click ACCESS THIS RESOURCE. 

Note: Google CoLab is a free service with a RAM limitation of approximately 13 GB, which may 

restrict the processing of larger datasets containing over 100,000 cells and 500 genes. 

 Make a copy of the notebook in your account by selecting File > Save a copy in Drive. 

  Click on the folder icon (1) to the left of the browser window to open the Files tab. 

 When the Files tab is open, click on Upload to session storage (2) to upload a .HDF5 file. 

 

 

 Click Refresh (3) to ensure the file is available and shown in the list. 

 

 

  After the file has uploaded (note the progress wheel at the bottom of the Files tab), select 

Runtime > Run all (4) to execute all cells in the notebook. 

 

2 

1 

3 

4 
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 The notebook will run clustering analysis and save the clustered file with a _clustered suffix to the file 

name (it may take some time to appear). Right-click on the file name to download 

(5) the clustered AnnData file from the CoLab instance. 

 

 

 Import the clustered AnnData file into the MERSCOPE Vizualizer by selecting File > Import data > 

Metadata > [feature set] from the MENU BAR. Select AnnData data format, navigate to the AnnData 

file, and click Import. 

 Both the clustering results and the two-dimensional representation of gene expression (e.g., 

UMAP) can be imported. 

– There are many parameters that can be adjusted to obtain the most biologically relevant cell 

clustering parameters for a given dataset. For a new dataset, the cell filtering criteria and 

clustering algorithm parameters should be carefully considered. 

  After the clustering annotations and UMAP are imported, the SCATTERPLOT will display the 

imported UMAP and a new category corresponding to the new clustering annotations is available 

and selectable from the SPATIAL FEATURES PANEL - CELLS. To color the cells using the clustering 

annotations, select the clustering annotations in the Active category 

menu, select Active category in the Color by menu, and ensure the cells layer is toggled on in the 

Spatial Settings menu. 

  The gene expression for each cluster can be displayed in the HEATMAP. Toggle on the 

Group by active category slider in the Heatmap Toolbar. 

  The UMAP can be colored by gene expression by selecting Count or Z-score (among others) from 

the Color by menu in the SPATIAL FEATURES PANEL - CELLS. 

5 
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SYSTEM RECOMMENDATIONS 

For optimal performance, the MERSCOPE Vizualizer software should be run on a system with the 

following minimum criteria: 

• Processor: Intel Core i9 

• RAM: 32 GB 

• Graphics: NVIDIA GeForce RTX 3080-10 Gb 

• SSD Capacity: 1 TB 

The MERSCOPE Vizualizer software can be run on a system with lower capability, but may result in 

suboptimal performance, especially for large datasets. 

macOS 12 (Monterey) is recommended, where applicable. 

In the absence of an optimal graphics card, the MERSCOPE Vizualizer software can be run on a GPU-

enabled AWS EC2 instance. Install NVIDIA drivers following the instructions under Option 4: NVIDIA 

gaming drivers (G5 and G4dn instances) at the following link: 

• https://docs.aws.amazon.com/AWSEC2/latest/WindowsGuide/install-nvidia-driver.  

html#nvidia-installation-options 

https://docs.aws.amazon.com/AWSEC2/latest/WindowsGuide/install-nvidia-driver.html#nvidia-installation-options
https://docs.aws.amazon.com/AWSEC2/latest/WindowsGuide/install-nvidia-driver.html#nvidia-installation-options
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MENU BAR 

 
Software Versions 

After an experiment is assembled in version 2.4, it cannot be opened in earlier versions because 

the folder structure of the assembled experiments is different. Experiments created in version 2.3 

are compatible with version 2.4. The MERSCOPE Vizualizer software version is found under the Help 

menu. 

 

File > Assemble Experiment 

To assemble an experiment: 

 

 File > Assemble experiment. 

 Enter Experiment name (this is then shown in the top bar of the MERSCOPE Vizualizer software 

window). 

  Click the Select output folder icon to save MERSCOPE Vizualizer metadata. 

  Click the Select datasets folder icon to select datasets (.VZG/.VZG2 files). 

  Click Build. 

– Multiple datasets can be assembled, but they must be from samples measured with the same 

MERSCOPE Gene Panel. To assemble multiple datasets, repeatedly click Select datasets and select 

the datasets for inclusion in the experiment. If datasets are in the same folder, use CTRL-SHIFT-

select to simultaneously select multiple datasets. 

– Assembling an experiment may take some time. A progress bar across the top of the 

spatial view window shows progress. 

– The MERSCOPE Vizualizer software creates a new folder with the experiment name in the 

output folder. 

– Only the transcripts and images layers are visible by default in the spatial view window 

when an experiment is loaded. Refer to Spatial Settings for more information. 
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File > Import Data 

The MERSCOPE Vizualizer software supports the import of data to feature sets via: 

• The open HDF5 format: https://www.hdfgroup.org/solutions/hdf5/ (annotated data, 

AnnData). 

• .CSV files or .PARQUET files (categories files and numeric categories files). A numeric categories 

file imports data to the scatterplot. Data in .CSV and .PARQUET files must be organized in the 

same way as exports from the MERSCOPE Vizualizer software. 

• .CSV files of ROI geometry data (of ROI feature sets only - this option is not available for the 

cells feature set). 

 

File > Import Data > Metadata 

After processing and analyzing annotated data, it can be imported into the MERSCOPE Vizualizer 

software with additional information (e.g., clusterization). 

Each experiment contains two default cell categories: 

• Datasets is an immutable cell category. This category contains all the cells in each 

dataset. 

• Custom Cell Groups. When an experiment is first assembled, a single cell group exists in this 

category (unclustered), which contains all the cells in a dataset. Custom cell groups can be 

created within this category. 

Each experiment contains one default ROI category: 

• Custom ROI Groups. When an experiment is first assembled, a single ROI group exists. Custom 

ROI groups can be created within this category. 

In addition to default cell/ROI categories, additional cell/ROI categories can be imported with annotated 

data (e.g., Leiden). Cell/ROI categories can be linked (nested) during import. 

In an experiment assembled from multiple datasets (.VZG/.VZG2 files), an exported metadata file contains 

all cells/ROIs from all datasets in the experiments, combined. In an imported metadata file, the clustering 

applies to all cells/ROIs in the experiment. 

 

To import annotated data (default): 

– Advanced import options are on the following page. If annotated data has previously been 

imported, the advanced Categories menu automatically appears. 

 File > Import data > Metadata > select the spatial feature set (cells or an ROI) to import data into. 

https://www.hdfgroup.org/solutions/hdf5/
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 Select the data format (AnnData [.HDF5], .CSV, or .PARQUET), navigate to the file location, and click 

Import. A Categories dialog box appears. 

  Check the categories for import. 

 Data available for the scatterplot (e.g., UMAP, tSNE) are imported by default, and can be renamed 

in the dialog box (under two-dimensional arrays for scatterplot). If not required, uncheck the 

appropriate option. Multiple selections can be checked/unchecked and a menu in the scatterplot 

window controls the data being displayed. 

  Click Import. 

– The imported cell categories appear in the active category selection menu in the cells feature 

set in the spatial features panel and the scatterplot is populated. 

– If a spatial feature set is empty (no features) an error message appears. 

 

To import annotated data (advanced): 

 File > Import data > Metadata > select the spatial feature set (cells or ROI) to import data into. 

 Select the data format of the file (AnnData [.HDF5], .CSV, or .PARQUET), navigate to the file location, and 

click Import. A Categories dialog box appears. 

 Click the Show advanced settings button (if available - if annotated data has previously been 

imported, the advanced Categories menu automatically appears). 

  Check the categories for import. 

 Check a cell/ROI category in the Existing experiment metadata list to import annotated data for 

that category. 

– The default cell/ROI categories (datasets and custom cell/ROI groups) are already selected in the 

existing experiment metadata list. 

  Cell/ROI categories can be linked. Select a subcategory to nest it under a category. 

– Linking imported cell/ROI categories may be useful when there is a connection between them - 

e.g., coarse and fine clusters. 

 Cell/ROI categories can be renamed. Click on the name and enter the new name. Each category 

should have a unique name. 

– If a previously used name is entered, the MERSCOPE Vizualizer software automatically 

renames the category to be imported to give it a unique name. 
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– Default cell categories (datasets and custom cell groups) cannot be renamed or linked. Default 

ROI categories can be removed only if the entire ROI feature set is removed. 

 Data available for the scatterplot (e.g., UMAP, tSNE) are imported by default, and can be renamed 

in the dialog box (under two-dimensional arrays for scatterplot). If not required, uncheck the 

appropriate option. Multiple selections can be checked/unchecked and a menu in the scatterplot 

window controls the data being displayed. 

  Click Import. 

– The imported cell/ROI categories appear in the active category menu in the feature set’s spatial 
features panel and the scatterplot is populated (as applicable). 

– If a ROI feature set is empty (no features) an error message appears. 

 

File > Import Data > Geometry > [Name of ROI Feature Set] 

To import the coordinates of ROI polygon vertices (coordinates should be in well-known text [WKT] 

format): 

  File > Import data > Geometry > [Name of ROI feature set]. 

  Navigate to the .CSV files for import. 

  Click Open. 

– The ROI groups will appear in the spatial features panel and the spatial view window. 
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File > Export Data 

The MERSCOPE Vizualizer software supports the export of data from feature sets to: 

• The open HDF5 format: https://www.hdfgroup.org/solutions/hdf5/ (annotated data, 

AnnData). 

• .CSV files or .PARQUET files (expression matrix files, categories files, and numeric categories files 

for cells and ROI feature sets; and feature metadata files for ROI feature sets). The feature 

metadata files contain feature volume/area and coordinates. 

• .CSV files of ROI geometries (to ROI feature sets only - this option is not available for the cells 

feature set). 

 

File > Export Data > Metadata 

Exported annotated data can be processed and analyzed in third-party tools for analyzing single-

cell gene expression data (e.g., Scanpy https://scanpy.readthedocs.io/en/latest/#). 

In an experiment assembled from multiple datasets (.VZG/.VZG2 files), an exported metadata file 

contains all cells from all datasets in the experiments, combined. 

To export annotated data: 

 File > Export data > Metadata > Select the spatial feature set (cells or ROI) to export data from. 

  Select the format of the file (AnnData [.HDF5], CSV, or PARQUET). 

 For export to .CSV and .PARQUET files: Check the files for export (expression matrix file, categories file, 

numeric categories file, and/or feature metadata file) and navigate to the location to save the files. 

Select the data type for the expression matrix file (count, z-score, normalized count, normalized z-score) 

from the menu. 

  Confirm all save locations and file names are per preferences. 

 Click Export. 

https://www.hdfgroup.org/solutions/hdf5/
https://scanpy.readthedocs.io/en/latest/
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File > Export Data > Geometry > [Name of ROI Feature Set] 

To export the coordinates of ROI polygon vertices: 

  File > Export data > Geometry > [Name of ROI feature set]. 

  Navigate to the location to save the .CSV files. 

  Click Save. 

 

Import/Export Leiden Colors From/To Scanpy 

If a color scheme is applied in Scanpy (e.g., Leiden), the color scheme will be imported with annotated 

data file and displayed in the MERSCOPE Vizualizer software. Any changes made to the colors in the 

MERSCOPE Vizualizer software will be exported in the AnnData file and may be imported into Scanpy. 

 

File > Open Experiment 

To open an experiment: 

 File > Open experiment. 

 Select the folder with the experiment data. 

It is also possible to open a recent experiment via Recent > [name of experiment]. 

– The MERSCOPE Vizualizer software opens the data folder and displays the experiment. If the 

experiment has annotated data, the software also loads all annotations. 

 

File > Save Experiment 

Assembled experiments are auto-saved after any changes are made in the application. All imported 

data and data created in the MERSCOPE Vizualizer software (custom cell groups, ROIs, gene groups, 

custom colors of cell/ROI/gene groups) are saved. 

To manually save an experiment at any time: 

 File > Save experiment. 

– All imported data and data created in the MERSCOPE Vizualizer software are automatically saved 

on closing the application. 
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Edit > Manage Image Channels 

Manage the image channels available in the experiment by unchecking/checking the boxes next to each 

channel. DAPI and PolyT channels are included in all experiments. Other imaging channels (up to 16) 

are available for import based on the use of auxiliary cell boundary stains/other auxiliary stains during 

data acquisition. Selected image channels are listed in the Spatial  Settings menu. 

 

Edit > Manage ROI Sets 

ROIs can be defined. There is one empty ROI feature set by default (named ROI). ROIs can be grouped 

in each ROI feature set. 

To manage ROI feature sets: 

  Edit > Manage ROI sets. 

  Click Add feature set to add a new ROI set. 

– A new ROI set with a default name appears in the dialog box. The default name can be changed in 

the dialog box. The name of the default ROI set (ROI) can also be changed from the dialog box. The 

ROI set name should be unique. 

  Rename the ROI set or accept the default name and click OK. 

– Multiple ROI sets can be added from the same dialog box. 

– A new ROI set appears in the spatial features panel. 

– ROI sets can be deleted or renamed from the manage ROI sets dialog box. 

 

Edit > Save Custom [Feature Set] Groups as New Copy 

To save custom cells/ROI groups as a new copy: 

 Edit > Save Custom Cells groups as new copy 

 Insert a name for the copy and click OK. 

– The copied and renamed custom cells/ROI groups can be selected in the spatial features panel from 

the Active Category menu. The copied group is immutable (only group colors can be changed by the 

user). 
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View 

Floating panels surround the spatial view window (refer to VIZUALIZER SOFTWARE USER  INTERFACE 

OVERVIEW for the default layout). 

• Scatterplot 

• Spatial features 

• FPS measuring (FPS = frames per second) 

• Genes 

• Details 

• Selected items 

– All panels except FPS measuring are shown by default after launching the MERSCOPE 

Vizualizer software. 

 

To manage floating panels: 

 View > toggle the applicable panel on and off. 
 

 To change the relative layout of the spatial view window and panels, toggle among the layout icons 

above the top right of the spatial view window. 

 To move a panel, move the cursor toward the top of the panel until the hand cursor appears. Click 

and drag to move the panel. Blue highlighting appears when hovering over a new location. 

 To create layered floating panels, move the cursor toward the top of the panel until the hand 

cursor appears. Pick up the panel, drag and drop it over an existing floating panel (blue 

highlighting appears when hovering over the new location). The layered panels can be selected 

from tabs at the bottom of the window. To return to a classic layout, toggle among the layout 

icons above the top right of the spatial view window. 

  To hide a panel, click X in the top right corner or toggle off from the View menu. 

 To resize a panel, hover over the bottom of a panel until the resize cursor appears. Click and drag 

to resize. 
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 When the FPS measuring panel is open, click Measure FPS and a number appears after some time 

(>20 is reasonable, >60 is optimal). 

– If FPS is <5, the user experience may be improved by upgrading the graphics capabilities of the 

computer. 

 

Help 

  Contact Vizgen help via support@vizgen.com. 

  About > version information. 

 About Qt (the C++ framework used for application development). 

  Open the report folder. 

 

Help > Archive Logs 

To create a .ZIP folder to share with support@vizgen.com: 

 Help > Archive logs. 

  Describe the problem in the text box. 

  Attach a screenshot, if applicable. 

  Click Save. 

The .ZIP folder will contain (as applicable): 

• The application version. 

• Information from the manifests of the last loaded experiments. 

• Information from the manifests of the last assembled datasets. 

• Debug information about application function. 

• Crash dump files. 

mailto:support@vizgen.com
mailto:support@vizgen.com
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SPATIAL VIEW WINDOW 

The MERSCOPE Vizualizer software has the capacity for two spatial view windows. The properties of 

each window are controlled independently. Each spatial view window displays a dataset in the 

experiment. If only one dataset is included during experiment assembly, only one spatial view 

window is visible by default. 

To open the second spatial view window, drag the right border of the spatial view window to the left. In 

the Spatial Settings menu of the new empty spatial view window, select the current dataset from the 

dataset menu (which is None by default). When two spatial views windows are open, it is possible to 

visualize the same dataset in the same or different locations. 

In the spatial view windows, users can work with existing experimental data (cells, transcripts, images) and 

create custom cell groups and ROIs. Cell selection and cell group formation 

or ROI selection and ROI group formation in the spatial view window and scatterplot are synchronized. 

 

Tooltips 

 Hover over a transcript, cell, or ROI to reveal a tooltip with information about the item. 

 

Navigation and Views 
 

 In the zoom/pan cursor mode (hand icon) (1), click and drag the hand cursor in the spatial view 

window and to move the content within the window. 

 There is a mini map (2) - a small scale preview of the spatial view window - in the top left corner of 

the window. Click and drag to move the mini map boundary (red box) to navigate the content of the 

spatial view window. This feature is particularly useful when zoomed in.  

NOTE: This mini map feature is based on Images and changing the Image Channel Selection and 

brightness (under Spatial Settings menu) also changes the mini map. In Vizualizer versions 2.3 and 

below, the minimap is based on density. 

 

1 

3 

2 
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 Toggle the mini map on and off via the map icon above the top left of the spatial view window (3). 

 

 

 Change the content of the spatial view window to full screen and back by toggling the expand icon 

above the top right of the window. 

 

Zoom and Scale 
 

To zoom in/out of the content in the spatial view window: 

  Rotate the mouse wheel. 

  Click the +/- buttons to either side of the scale box above the top right of the window. 

 Type in an exact zoom level in microns in the scale box. The value corresponds to the width of the 

spatial view window. A scale bar is always present in the bottom left of the window. 

  Select a zoom level in microns from the menu in the scale box. 

 

Information Panel 
 

 Toggle a summary of properties of the data displayed in the window on and off via the information icon 

above the top left of the spatial view window (1). 

 The information panel is displayed in the bottom left of the spatial view window (2), and includes the 

coordinates of the cursor in the spatial view window. 

  

1 

2 
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Export Image 
 

  Click the export icon above the top right of the spatial view window to export a .png file of the 

spatial view window. A .txt file with the same file name with details of the data in the image file is 

also created. 

 Changing the resolution factor of the .png file changes the resolution and size of the image file. The 

range of resolution factors depends on the rendering capabilities of the computer and the actual 

size of the exported spatial view window (a smaller window can be exported with a higher 

resolution factor). 

 

Spatial Settings 
 

To manage the properties of a spatial view window, toggle the spatial settings menu on and off via 

the tools icon above the top right of the spatial view window: 

  Select the dataset visible in each spatial view window in the Dataset menu. 

 To choose the z-plane visible in the spatial view window, select from the Z-plane menu. The active 

(selected) z-plane or all z-planes can be selected for each layer. For .VZG2 files, only the active z-plane is 

available for Images layer. 

– Z-plane 0 includes the data at 1.5 microns from the MERSCOPE Slide. Z-planes 1, 2, 3, etc are at an 

additional fixed 1.5 microns away from the MERSCOPE Slide. The number of z-planes depends on 

the thickness of the sample defined during data acquisition. 

NOTE: Transcripts are no longer divided by z planes for .VZG2 file format. Transcripts from all 

layers are represented in a single image. 

 Only the transcripts and images layers are visible in the spatial view window when an experiment is 

loaded. Additional layers are ROI feature sets, cells, and density. The density layer, however, is only 

available for VZG files. 

 To toggle layers on and off in the spatial view window, check/uncheck the layer in the spatial settings 

menu or the shortlist of layers (transcripts, cells or the selected ROI feature set, images) above the top left of 
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the spatial view window. 

 

  To manage the order of layers, click the Reorder layers button and a dialog box appears: 

• The transcripts layer is always on top (first on the list) so that the user can always select 

transcripts in the spatial view window. 

• The active feature set is always listed second. Switching the active feature set in the spatial 

features panel automatically changes the layer list order. Selection tools always work on the 

active feature set. 

• For the remaining layers, drag and drop a layer into a different location to reorder layers. 

 Each layer represents a particular type of spatial data. Cells and transcripts layers can be viewed 

across all z-planes or the active z-plane selected at the top of the spatial settings menu: 

• Transcripts. Shows the checked gene transcripts as dots. A slider controls the intensity. A 

separate slider controls the size of the transcripts. 

• Cells. Shows the polygons representing cells, identified during data processing. The slider 

controls the transparency. 

NOTE: On distant zoom levels, Cell Selection by polygon/rectangle selects cells whether the 

current z-plane contains cell polygon or not. This is because cell selection is done using cell 

center coordinates. While on the close zoom levels, cell selection by polygon or rectangle 

selects cells whether current z-plane contains cell polygon or not, as in this case the 

selection is done using cell polygons. 

• ROI feature sets. Shows the ROIs in the set. Each ROI feature set has its own layer. The 

slider controls the transparency. ROIs span all z-planes and an ROI has the same boundary 

for all z-planes. 

• Density. Shows the density of checked gene transcripts. The slider controls the 

transparency. Density is available only for .VZG datasets. 

• Images. Images of the image channels, if checked (e.g., DAPI and PolyT). Up to 16 image 

channels can be displayed at the same time (Edit > Manage Image Channels). The Images 

slider is used to set the overall transparency for the images. Individual channel sliders are 

used to set minimum and maximum contrast thresholds for each channel. Only one z-plane 

(active) can be selected in the image layer. 

NOTE: All image channels will have the same number of z-planes for VZG2. Furthermore, 

images can have one z-plane (2D mode) and no z-plane switching in this case for VZG2.  

 

Additional Settings (Under Spatial Settings Menu) 

  To define the coordinate at the center of the spatial view window, enter X and Y values. 

 To rotate the content in the spatial view window, adjust the Rotate image setting. To rotate 

clockwise, enter a positive number. To rotate counterclockwise, enter a negative number. 


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  Click the Background color palette to change the background color of the window. 

– If image channels are selected and/or not transparent, the background color change is not visible 

until the images are deselected in the spatial settings menu or from the layers check boxes above 

the top left of the spatial view window. 
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DETAILS AND SELECTED ITEMS PANELS 

 
Details Panel 

The details panel displays details of a selected gene, cell, or ROI, including a list of genes expressed in 

a selected cell/ROI. Data are organized under spatial and heatmap headings. The information can be 

copied to clipboard using the copy icon at the top right of the details panel. 

 

Selected Items Panel - Cells 

  The selected items panel indicates the active feature set, i.e., the spatial feature set 

selected in the spatial features panel. 

 When the cells feature set is active in the spatial features panel, all cells selected in the spatial 

features panel, the spatial view window, scatterplot, and/or heatmap are listed in the selected 

items panel. 

 Cell indexes and identification numbers of the selected cells are also listed. The number of selected 

cells is listed in parentheses next to the panel title Selected items. 

 Click Clear all on the selected items panel to clear the selection in all panels. The selected item list is 

empty if no cells are selected (when in the cells feature set). 

  Switching between spatial feature sets (cells or ROI) clears the selected items list. 

 Individual cells in the list can be selected by clicking the cell in the list and the cell’s location is 
identified by crosshairs in the spatial view window, scatterplot, and heatmap. The location is 

identified in the heatmap as long as the Group by active category slider is toggled off in the 

Heatmap Toolbar. 

  Alternatively, copy the cell name (e.g., 300948112130576190679118935843036609088) to 

clipboard. In the selected items panel, right-click (or Ctrl+V) to paste the cell name, and then select 

the cell in the single-item list to identify (crosshairs) the cell in the spatial view window, scatterplot, 

and heatmap. 

  Cell groups (Cell Groups) can be created from this panel. 
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Selected Items Panel - ROI 

  The selected items panel indicates the active feature set, i.e., the spatial feature set 

selected in the spatial features panel. 

 When an ROI feature set is active in the spatial features panel, all ROIs selected in the spatial 

features panel, spatial view window, scatterplot, and/or heatmap are listed in the selected items 

panel. 

  The number of selected ROIs in the group is listed in parentheses next to the panel title 

Selected items. Right-click on an ROI name to delete it. 

 Click Clear all on the selected items panel to clear the selection in all panels. The selected item list is 

empty if no ROIs are selected (when in an ROI feature set). 

  Switching between spatial feature sets (cells or ROI) clears the selected items list. 

 Individual ROIs can be selected by clicking the ROI in the list and the center of the ROI is identified by 

crosshairs in the spatial view window, scatterplot, and heatmap. The location is identified in the 

heatmap as long as the Group by active category slider is toggled off in the Heatmap Toolbar. 

  ROI groups (ROI Construction and ROI Groups) can be created from this panel. 
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SPATIAL FEATURES PANEL - CELLS 

 
Select the Cells Feature Set 

 

The cells feature set and ROI feature sets (Select an ROI Feature Set) are individually addressable by 

selection of a feature set at the top of the spatial features panel. The selected items panel also indicates 

the active feature set, i.e., the spatial feature set selected in the spatial features panel. The active 

feature set is always displayed in front of other feature sets in the spatial view window and selection 

tools are only applicable to the active feature set. 

 

Cells 

The cell groups available in each cell category are listed in the cells feature set of the spatial features panel. 

Each experiment contains two default cell categories: 

• Datasets is an immutable cell category. This category contains all the cells in each dataset. 

• Custom Cell Groups. When an experiment is first assembled, a single cell group exists in this 

category (unclustered), which contains all the cells in an experiment. Custom cell groups can be 

created within this category. 

In addition to default cell categories, additional cell categories can be imported with annotated data (e.g., 

Leiden). 

It is possible to make a copy of custom cell groups (Edit > Save Custom [Feature Set] Groups  as New 

Copy). 
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Active Category 

Select an active category from the menu near the top of the spatial features panel. The menu contains 

the default categories and any imported cell categories. The data of the active category is displayed in 

the spatial view window, scatterplot, and heatmap. 
 

 

Selection Toolbar (Cells) 

The cells layer in the spatial view window must be turned on to select cells and define cell groups. To 

toggle the cells layer on and off, check/uncheck the cells layer in the Spatial  Settings menu or in the 

shortlist of layers above the top left of the spatial view window (available when the cells feature set is 

selected). 

A selection toolbar is available above the top left of the spatial view window; the selection tools also 

work in the scatterplot. 

 

 Multi-transcript selection (1) enables users to select all instances of a gene transcript at the same 

time. Click away from a selected transcript or press Esc and all Checked Genes transcripts 

reappear.  

NOTE: For experiments created from.VZG2 files, multi-transcript selection works only with the 

closest Level of Details (LOD0). 

 Single-feature selection (Cells) (2) enables users to select a single cell. Click/click again to select/deselect 

an individual cell; click Clear all on the selected items panel, or press Esc to clear the selection. Select 

multiple cells by Ctrl-clicking single cells one-by-one. To deselect a cell from the selection, Ctrl-click in the 

spatial view window, scatterplot, or heatmap (as long as the Group by active category slider is toggled off in 

the Heatmap Toolbar). 

1 2 3 4 5 
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  Multi-feature selection (Cells) (3) enables users to select all cells in a cell group. Click/click again to 

select/deselect a cell group; click Clear all on the selected items panel to clear the selection. Select 

multiple cell groups by Ctrl-clicking cell groups one-by-one. 

  Rectangle selection (4). Drag and click to define a rectangle over the display to select cells at least 

partially within the rectangle. Press Ctrl and draw another rectangle to add cells to the previous 

selection. Draw another rectangle without Ctrl away from the original to reset the selection. Draw 

another rectangle within the first to select the subset of cells. Switch to the single-feature selection 

tool and click in a blank space in the spatial view window, click Clear all on the selected items panel, 

or press Esc to clear the selection. 

  Polygonal lasso selection (5). Click each point to draw a polygon over the display. Close the polygon 

to select the cells at least partially within the polygon. Press Ctrl and draw another polygon to add 

cells to the previous selection. Draw another polygon without Ctrl away from the original to reset 

the selection. Draw another polygon within the first to select the subset of cells. Switch to the 

single-feature selection tool and click in a blank space in the spatial view window, click Clear all on 

the selected items panel, or press Esc to clear the selection. 
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Cell Groups 

Each cell can belong to either one cell group or no cell groups. A cell cannot belong to multiple cell 

groups. 

To create a cell group: 

 Select cells in the spatial view window, scatterplot, or heatmap. All selected cells are listed in the 

selected items panel. Cell indexes and identification numbers of the selected cells are also listed. 

The number of selected cells is listed in parentheses next to the panel title Selected items. 

 Click on a cell in the selected items panel list and its location is identified by crosshairs in the spatial 

view window and scatterplot. 

 To save selected cells as a cell group, enter a cell group name in the text box at the bottom of the 

selected items panel and click Save group. The cell group appears in the custom cell groups list in 

the spatial features panel. The number of cells in the group is listed in parentheses next to the cell 

group name. 

 

– The newly created group always appears in the custom cell group category, regardless of which 

active category is selected. 

– If a new cell group is created and the cell already belongs to a previously-defined cell group, 

the cell belongs to the newer group and is deleted from the previous group. 

– After saving a cell group, the MERSCOPE Vizualizer software clears the selection. 

– It is not possible to exclude (deselect) individual cells from a saved group. 

To import a cell group: 

 With an existing dataset open, export AnnData (File > Export Data) and export the cells feature set. 
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  Import AnnData into a Jupyter notebook (Open Custom Cell Clustering Analysis). 

 

  To create a new cell group, generate a new column of cell metadata. 

– In the example below, a new column of metadata (named new-group) was formed 

containing cells expressing the Slc17a7 gene at a high or low level. 

 

 

  The Jupyter notebook saves this AnnData to a new .HDF5 file. 

  Import this AnnData into the Vizualizer software (File > Import Data). 

 Select the new column of cell metadata under the list of categories (e.g., new-group in the example 

above). 

 The new cell category is available for selection and manipulation within the Vizualizer software. 
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Checked Cell Groups 

 Select an active category from the menu in the spatial view window. The corresponding cell group 

tree structure appears below in the window. Click the arrow to the left of the parent cell group to 

expand the tree structure. 

 Checked cell groups appear in the spatial view window and scatterplot, and are also included in the 

heatmap. 

 To select all cells in a checked cell group, click on the cell group name in the spatial features 

panel. Selected cells are shown in the spatial view window, scatterplot and heatmap, and are 

also listed in the details panel. 

 In the case of multilevel hierarchy, checking a parent group applies the same status to all child 

groups. 

 

Unchecked Cell Groups 

 Unchecked cells are hidden or colored gray in the spatial view window and scatterplot, and not 

included in the heatmap. 

 Hide/unhide unchecked cell groups in the spatial view window and scatterplot by toggling the Hide 

features of unchecked groups slider in the spatial features panel. 

 In the case of multilevel hierarchy, unchecking a parent group applies the same status to all child 

groups. 

 

Cell Group Settings 

 To color any cell group, left-click the color spot to the right of the group name and select a color. 

– The color is applied to the cell group in the spatial view window, scatterplot, and heatmap. 

  Right-click on any cell group name to: 

• Add/edit description of the cell group. 

• Reset color back to the default color. 

• Edit categories to rename or remove imported categories. 

• Remove group. The option to remove any custom cell group created in the MERSCOPE 

Vizualizer software. Default or imported cell groups do not have the remove option. Cells from 

the removed group return to the unclustered group. 

• Copy to clipboard. Copies the cell identification numbers in the cell group to clipboard. It is 

pasted as a comma delimited list. 

• Export. Exports the cell identification numbers to a .CSV file format. 
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  Right-click on an active category name to: 

• Reset color for all groups in the category back to the default colors. 

• Edit categories to rename or remove imported categories. 

 

Cell Color Options 

Cells can be colored according to cell category or a number of gene expression level characteristics. 

Cells can be colored according to: 

• Active category 

• Count 

• Z-score 

• Normalized 

• Normalized z-score 

 Cells are colored by active category by default. To change the coloring mode, select the option from 

the Color by menu at the top of the spatial features panel. 

– Active category applies the cell group colors defined by the color spot to the right of the cell group 

names. 

 Selection of an expression level characteristic reveals a color scheme menu. 

 The three-color scheme based on minimum, center, and maximum values for each characteristic can 

be defined. Click on a color spot to change the color. Click on the center spot to convert to a two-

color scheme (spot becomes transparent). Click again on the center spot to convert back to a three-

color scheme and/or change the color. 

 Adjust the Brightness slider to define the minimum and maximum thresholds for the characteristic. 

– The expression level characteristics for every cell are calculated dynamically based on the total 

expression of the checked genes. To color based on the expression of a single gene or a subset/group 

of genes, uncheck all genes and then check a single gene or subset/group of genes. 
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SPATIAL FEATURES PANEL - REGIONS OF INTEREST 

By default, there is one empty ROI feature set (named ROI) in the MERSCOPE Vizualizer software. ROI 

feature sets can be renamed or added via the Edit > Manage ROI Sets menu. 

 

Select an ROI Feature Set 
 

ROI feature sets and the cells feature set (Select the Cells Feature Set) are individually addressable by 

selection of a feature set at the top of the spatial features panel. The selected items panel also indicates 

the active feature set, i.e., the spatial feature set selected in the spatial features panel. The active 

feature set is always displayed in front of other feature sets in the spatial view window and selection 

tools are only applicable to the active feature set. 

 

Selection Toolbar (ROIs) 

An ROI feature set layer in the spatial view window must be turned on to see ROIs. To toggle ROI 

feature set layers on and off, check/uncheck an ROI feature set layer in the Spatial  Settings menu or in 

the shortlist of layers above the top left of the spatial view window (available when an ROI feature set 

is selected). 

When an ROI feature set is selected in the spatial features panel, a Draw ROI polygon icon (6) appears in 

the selection toolbar above the top left of the spatial view window; the selection tools also work in the 

scatterplot. 

 

 

 Multi-transcript selection (1) enables users to select all instances of a gene transcript at the same 

time. Click away from a selected transcript or press Esc and all Checked Genes transcripts 

reappear. 

NOTE: Multi-transcript selection works on any LOD (Level of Details) for .VZG format, but for 

.VZG2 datasets multi-transcript selection works only on LOD 0. 

 Single-feature selection ([Name of ROI feature set]) (2) enables users to select a single ROI. Click/click 

again to select/deselect an individual ROI; click Clear all on the selected items panel, or press Esc to clear 

1 2 3 4 5 6 
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the selection. Select multiple ROIs by Ctrl-clicking single ROIs one-by-one. To deselect a ROI from the 

selection, Ctrl-click in the spatial view window, scatterplot, or heatmap (as long as the Group by active 

category slider is toggled off in the Heatmap Toolbar). 

 Multi-feature selection ([Name of ROI feature set]) (3) enables users to select all ROIs in an ROI 

group. Click/click again to select/deselect an ROI group; click Clear all on the selected items panel 

to clear the selection. Select multiple ROI groups by Ctrl-clicking ROI groups one-by-one. 

 Rectangle selection (4). Drag and click to define a rectangle over the display to select ROIs at least 

partially within the rectangle. Press Ctrl and draw another rectangle to add ROIs to the previous 

selection. Draw another rectangle without Ctrl away from the original to reset the selection. Draw 

another rectangle within the first to select the subset of ROIs. Switch to the single-feature selection 

tool and click in a blank space in the spatial view window, click Clear all on the selected items panel, 

or press Esc to clear the selection. 

 Polygonal lasso selection (5). Click each point to draw a polygon over the display. Close the polygon 

to select the ROIs at least partially within the polygon. Press Ctrl and draw another polygon to add 

ROIs to the previous selection. Draw another polygon without Ctrl away from the original to reset 

the selection. Draw another polygon within the first to select the subset of ROIs. Switch to the 

single-feature selection tool and click in a blank space in the spatial view window, click Clear all on 

the selected items panel, or press Esc to clear the selection. 

 Draw ROI polygon (6). Click each point to draw a polygon over the display. Close the polygon and a 

dialog box appears. 

 

ROI Construction and ROI Groups 

 To draw an ROI, use the Draw ROI Polygon tool. Click each point to draw a polygon over the display. 

Close the polygon and a dialog box appears. Press Esc before closing the polygon to reset the 

drawing. 

 Enter a name for the newly drawn ROI. 

 Select the group that the ROI should be added to or create a new group. To create a new group, 

overwrite the default group name in the ROI group box. To select from existing groups, click in the 

ROI group box and a list of existing ROI groups appears. 

  Click Cancel to remove the ROI just drawn. 

– When an ROI feature set is selected in the spatial features panel, all ROIs in any selected group are 

listed in the Selected Items Panel - ROI. The number of selected ROIs in the group is listed in 

parentheses next to panel title Selected items. Individual ROIs can be selected by clicking the ROI in 

the list and the center of the ROI is identified by crosshairs in the spatial view window. 
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– To save selected ROIs as a new ROI group, enter an ROI group name in the text box at the bottom 

of the selected items panel and click Save group. The ROI group appears in the custom ROI groups 

list in the spatial features panel. The number of ROIs in the group is listed in parentheses next to the 

ROI group name. 

– To delete an ROI, right-click on the ROI name in the selected items panel. 

– If a new ROI group is created and an ROI already belongs to a previously-defined ROI group, the ROI 

belongs to the newer group and is removed from the previous group. If the ROI group is empty (no 

ROIs) after moving an ROI, the group will disappear from the list in the spatial features panel. 

– After saving an ROI group, the MERSCOPE Vizualizer software clears the selection. 

– It is not possible to exclude (deselect) individual ROIs from a saved group. 

 

Checked ROI Groups 

  Checked ROIs appear in the spatial view window and scatterplot, and are included in the 

heatmap. 

 To select all ROIs in a checked ROI group, click on the ROI group name in the spatial features panel. 

The ROIs in the group are listed in the selected items panel. 

 In the case of multilevel hierarchy, checking a parent group applies the same status to all child 

groups. 

 

Unchecked ROI Groups 

 Unchecked ROIs are hidden or colored gray in the spatial view window and scatterplot and not 

included in the heatmap. 

  Hide/unhide unchecked ROI groups by toggling the Hide features of unchecked groups 

slider in the spatial features panel. 

 In the case of multilevel hierarchy, unchecking a parent group applies the same status to all child 

groups. 

 

ROI Group Settings 

 To color any ROI group, left-click the color spot to the right of the group name and select a color. 

– The color is applied to the ROI group in the spatial view window, scatterplot, and 

heatmap. 

  Right-click on any ROI group name to: 

• Add/edit description of the ROI group. 
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• Reset color back to the default color. 

• Edit categories to rename or remove imported categories. 

• Remove group. The option to remove any custom ROI group created in the MERSCOPE Vizualizer 

software. Default or imported ROI groups do not have the remove option. ROIs from the 

removed group return to the unclustered group. 

• Copy to clipboard. Copies the ROI names in the ROI group to clipboard. It is pasted as a comma 

delimited list. 

• Export. Exports the ROI names to a .CSV file format. 

  Right-click on an active category name to: 

• Reset color for all groups in the category back to the default colors. 

• Edit categories to rename or remove imported categories. 

 

ROI Color Options 

ROIs can be colored according to ROI category or a number of gene expression level characteristics. 

ROIs can be colored according to: 

• Active category 

• Count 

• Z-score 

• Normalized 

• Normalized z-score 

 ROIs are colored by active category by default. To change the coloring mode, select the option from 

the Color by menu at the top of the spatial features panel. 

– Active category applies the ROI group colors defined by the color spot to the right of the ROI group 

names. 

  Selection of an expression level characteristic reveals a color scheme menu. 

 The three-color scheme based on minimum, center, and maximum values for each characteristic can 

be defined. Click on a color spot to change the color. Click on the center spot to convert to a two-

color scheme (spot becomes transparent). Click again on the center spot to convert back to a three-

color scheme and/or change the color. 

 Adjust the Brightness slider to define the minimum and maximum thresholds for the characteristic. 

– The expression level characteristics for every ROI are calculated dynamically based on the total 

expression of the checked genes. To color based on the expression of a single gene or a subset/group 

of genes, uncheck all genes and then check a single gene or subset/group of genes. 
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SCATTERPLOT 

The MERSCOPE Vizualizer software has a single scatterplot. The scatterplot can display two- dimensional 

arrays, such as cells in dimensionality reduced gene expression space (e.g., UMAP/ tSNE) or other user-

imported two-dimensional arrays (e.g., cell volume versus transcript count). Clustering modes are imported 

with annotation data (AnnData). The active feature set is indicated in the scatterplot if features are colored 

by expression. If features are colored by active category, this category is shown in the scatterplot.. If there 

are no two-dimensional data for an ROI feature set, the scatterplot will be empty. 

– Only cells or ROIs from the experiment that have imported annotation are shown in the 

scatterplot. E.g., if some cells or ROIs were filtered during clustering, they are not displayed in 

the scatterplot. 

 

Translate and Zoom 

 In the zoom/pan cursor mode (hand icon) from above the spatial view window (Navigation  and 

Views), click and drag the cursor in the scatterplot to translate the content. 

 To zoom in/out of the content in the scatterplot, rotate the mouse wheel. 

 

Select Array 
 

 If multiple arrays were imported, select the array visible in the panel from the menu above the 

scatterplot (1). 

 

Export Image 

 Click the export icon (2) above the scatterplot to export a .png file of the content. 

 Changing the resolution factor of the .png file changes the resolution and size of the image file. The 

range of resolution factors depends on the rendering capabilities of the computer and the actual 

size of the exported spatial view window (a smaller window can be exported with a higher 

resolution factor). 

2 1 
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Selection Toolbar (Cells or ROI) 

Selection toolbar functions can be applied to the scatterplot in the same way as in the spatial view 

window. Refer to Selection Toolbar (Cells) or Selection Toolbar (ROIs) for more information. 

Cell groups or ROI groups can be created in the scatterplot in the same way as in the spatial view 

window. Refer to Cell Groups or ROI Construction and ROI Groups for more information. 
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GENES TREE 

The genes panel controls the representation of gene products - transcripts - in the MERSCOPE Vizualizer 

software. 

In the spatial view window, transcripts are represented by dots and all transcripts that are products of 

the same gene have the same color. 

The transcripts layer in the spatial view window must be turned on to see transcripts. The transcripts 

layer is visible by default when an experiment is loaded. To toggle the transcripts layer on and off, 

check/uncheck the transcripts layer in the Spatial Settings menu or in the shortlist of layers above the 

top left of the spatial view window. 

 

Checked Genes 

 All genes included in an experiment are listed in the genes panel. The number of genes in the gene 

panel is listed in parentheses next to the software panel title Genes and next to All in the list. The 

number of transcripts of each gene in the experiment (both inside and outside cell boundaries) is 

listed in parentheses next to the gene name. The number of genes in Gene Groups are listed in 

parentheses next to the gene group. 

 To visualize all transcripts of a gene/gene group, check the box next to the gene/gene group name. 

  Checked gene transcripts appear in the spatial view window. 

  Checked genes are displayed in the heatmap. 

  Selected genes are also highlighted in the heatmap (Heatmap Highlighting). Click on the gene name 

in the genes panel to select the gene. 

 In the case of multilevel hierarchy, checking a parent group applies the same status to all child 

groups. 

 

Unchecked Genes 

 Unchecked genes are hidden or colored gray in the spatial view window and scatterplot, and not 

included in the heatmap. 

  Hide/unhide unchecked genes by toggling the Hide transcripts of unchecked genes slider in the 

genes panel. 

 In the case of multilevel hierarchy, unchecking a parent group applies the same status to all child 

groups. 



MERSCOPE
® 

Vizualizer Software User Guide 

91600100 • Rev D TABLE OF CONTENTS Page 46 of 53 

 

 

 

Gene Color Settings 

 To change the color of gene transcripts, left-click the color spot to the right of the gene name and 

select a color. 

 

Gene Settings 

  Right-click on any gene name/color spot to see a menu to: 

• Add/edit description of the gene. 

• Move to another gene group - select the gene group from the menu or create a new group. 

• Reset color back to the default color. 

• Copy to clipboard. Copies the gene group, gene name, and color information in the gene to 

clipboard. It includes any description of the gene. It is pasted as a comma delimited list. The 

gene must be highlighted (left-click) prior to right-click to copy (otherwise information is not 

copied). 

• Export. Exports the gene group, gene name, gene description, and color information to a .CSV 

file format. The gene must be highlighted (left-click) prior to right-click for export (otherwise 

the exported file will not contain information). 

• Import. Gene groups, description, and color can be imported from a .CSV file. Click Import to 

upload a .CSV file, which must contain 4 columns: gene group, gene name, gene description, 

gene color; gene names are immutable. It is recommended to first export a .CSV file, edit it, 

and then import it. 
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Gene Highlighting 

  Left-click a gene or gene group to highlight it in the genes tree. 

  Ctrl-click to highlight multiple genes. 

  Right-click to move selected gene(s) to another group or create a new group. 

  Highlighted genes are marked by a blue bar in the genes tree. 

  Use the up/down arrow keys to move highlighting up/down in the genes tree. 

  Unchecked genes are not highlighted if Hide transcripts of unchecked genes is toggled on. 

 In the spatial view window: 

• Highlighted gene(s) are colored. 

• Non-highlighted genes are gray. 

• Hide/unhide selected genes by toggling the Hide Transcripts of Unselected Genes slider in the Genes 

panel. 

 In the heatmap: 

• Highlighted gene(s) are marked by a blue bar (Heatmap Highlighting). 

 A gene must be checked in order to be shown in the visualization regardless of highlighting. 
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Gene Groups 

Each gene can belong to either one gene group or no gene groups. A gene cannot belong to multiple gene 

groups. 

Genes without a group are designated ungrouped. A gene group can be created from checked genes, 

from highlighted genes, or an empty gene group can be created. If a gene group is deleted, the genes in 

the group automatically return to the ungrouped status. It is not possible to delete a gene from the 

genes panel. 

To create a gene group from checked genes: 

  Check genes in the genes panel. 

  To save checked genes as a gene group, enter a gene group name in the text box at the bottom of 

the genes panel and click Save. The gene group appears in the tree structure in the genes panel. The 

number of genes in the group is listed in parentheses next to the gene group name. The number of 

transcripts of each gene in the experiment (both inside and outside cell boundaries) is listed in 

parentheses next to the gene name. 
 

  Click the arrow to the left of the parent gene group to expand the tree structure. 

– If a new gene group is created and the gene already belongs to a previously-defined gene group, 

the gene belongs to the newer group and is deleted from the previous group. 

 To create an empty gene group, ensure no genes are selected, enter a gene group name in the text 

box at the bottom of the genes panel and click Save. 

– An empty gene group can be useful if users want to create a gene group in a stepwise fashion, 

adding one gene at a time, for example. 

 Gene groups can be created by right-click from highlighted genes (Move to > Create new 
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group). 

 Gene groups can be created from the heatmap by clicking on an individual cluster or by clicking the 

hierarchy button  in the genes panel when hierarchical clustering is selected in heatmap 

toolbar. 

  Gene groups can be highlighted in the heatmap. 

 

Search for Genes 

  Use the search bar at the top of the genes panel to search for genes in all groups. 

 

Gene Group Settings 

  Right-click on any gene group name/color spot to see a gene group menu to: 

• Color by group(s). Changes all genes in the same group to the same color. To change the color 

of a gene group, left-click the color spot to the right of the gene group name and select a color. 

• Reset color back to the default color. 

• Delete group. Provides the option to delete any gene group created in the MERSCOPE Vizualizer 

software. When a gene group is deleted, the genes in the group return to the ungrouped status. 

• Copy to clipboard. Copies the gene group, gene name, and color information of all genes in the 

gene group to clipboard. It is pasted as a comma delimited list. The gene group must be 

highlighted (left-click) prior to right-click to copy (otherwise information is not copied). 

• Export. Exports the gene group, name, gene description, and color information to a .CSV 

file format. It is possible to save the different types of genes grouping, e.g., 

grouping based on hierarchical clustering, DEG analyses, etc. The gene group must be 

highlighted (left-click) prior to right-click for export (otherwise the exported file will not contain 

information). 

• Import. Gene groups, description, and color can be imported from a .CSV file. Click Import to 

upload a .CSV file, which must contain 4 columns: gene group, gene name, gene description, 

gene color; gene names are immutable. All genes from gene panel will be regrouped 

according to the information in the .CSV file. It is recommended to first export a .CSV file, edit 

it, and then import it. 
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HEATMAP 

The MERSCOPE Vizualizer software has a single heatmap, where users can view gene expression data 

according to spatial feature categories and groups. All cells from all datasets are shown in the heatmap 

and scatterplot. To view cells from a specific dataset(s) in an experiment assembled from multiple 

datasets, select Datasets in the Active Category menu in the spatial features panel and uncheck any 

listed dataset to hide the cells from that dataset. 

 

Navigation and Selection 
 

 In the zoom/pan cursor mode (arrow icon) (1), click and drag the hand cursor in the heatmap to 

translate the content of the window. 

  In the gene selection cursor mode (row icon) (2), click a gene in the heatmap to select it. 

Information on the selected gene appears in the details panel. 

 In the feature selection cursor mode (column icon) (3), click a feature in the heatmap to select it. 

Information on the selected feature appears in the selected items panel. 

 

Zoom and Scale 
 

  To zoom in/out of the content in the heatmap, rotate the mouse wheel. 

 In the zoom to rectangle mode (1), draw a rectangle over the heatmap to expand the contents of 

the rectangle. 

  Use the reset zoom mode (2) to visualize the entire heatmap. 

 

Export 
 

 Click the export icon to export a .png file of the heatmap or export the filtered expression matrix to 

a .CSV file or .PARQUET file. 

1 2 3 

1 2 
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Heatmap Toolbar 

The spatial feature set (cells or ROI) selected in the spatial features panel is visible in the heatmap 

and the data are ordinarily displayed per feature. Only Checked Cell Groups or Checked ROI 

Groups, and Checked Genes are visible in the heatmap. 

 

 The active category selected in the cells/ROI feature set is displayed in the heatmap. To display data 

according to cell/ROI groups in a category, toggle on the Group by active category slider (1). 

– All cell categories are shown in the heatmap bar (at the top) in the order they appear in the active 

category list in the spatial features panel. When the Group by active category slider 

(1) is toggled on, only the active category is shown in the heatmap bar. 

 Cells/ROIs can be sorted according to count or by count within each category (count+category) via 

the feature sort by menu (when the cells feature set is selected) (2). 

 Genes can be sorted according to count, variance, or hierarchical clustering via the gene sort by 

menu (3). If hierarchical clustering is selected, it is possible to create gene groups via the hierarchy 

button in the genes panel (Gene Groups). 

 When the Group by active category slider (1) is toggled on, the feature sort by menu (2) enables 

sorting by hierarchical clustering or count. The sliders on each axis of the heatmap (bottom left for 

genes and top right for category) adjust the level of the hierarchical dendrograms that are displayed 

as brackets on either axis (sliders are only visible when hierarchical sorting is selected). 

– If selected genes or feature groups are changed, orange warning triangles  appear next to 

the sort by menus and the dendrograms appear orange. Click the recalculate hierarchical 

clustering button to the top left of the heatmap (indicated by an orange warning 

triangle/circular arrow) to adjust the clustering according to the new selections. 

 Spatial features (cells or ROI) in the heatmap can be colored according to gene expression level. 

Spatial features can be colored according to count, Z-score, normalized, and normalized z-score (4). 

 The three-color scheme based on minimum, center, and maximum values for each characteristic can 

be defined. Click on a color spot to change the color. Click on the center spot to convert to a two-

color scheme (spot becomes transparent). Click again on the center spot to convert back to a three-

color scheme and/or change the color. 

1 2 3 

4 
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  Adjust the slider to define the minimum and maximum thresholds for the characteristic. 

 

Heatmap Settings 

To manage properties of the heatmap, toggle the heatmap settings menu on and off via the funnel 

icon above the top right of the heatmap. 

 

 Adjust the Variance of highly variable genes slider to set a cutoff for genes to be displayed in the 

heatmap, and click Apply. When adjusting the slider, the number of kept genes appears under the 

box, next to an information icon. 

– After clicking Apply, the genes below cutoff are unchecked in the genes panel. To reset the genes 

included in the heatmap, re-check the genes in the genes panel. 

  Adjust the Z-score of differentially expressed genes (DEG) slider to set a cutoff for genes to be 

displayed in the heatmap, and click Apply. When adjusting the slider, the number of kept genes 

appears under the box next to an information icon. 

• Only checked gene groups are taken into account in DEG calculation. 

• At least two cell groups or ROI groups should be checked for Z-score or DEG 

calculation. 

• DEG calculation for a large number of groups may take some time (up to 60 sec). 

– If the Z-score of differentially expressed genes slider is not visible, click Recalculate DEG 

and the slider will appear. This may take some time. 

– After clicking Apply, the genes below cutoff are unchecked in the genes panel. To reset the genes 

included in the heatmap, re-check the genes in the genes panel. 
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Heatmap Highlighting 
 

Locations of selected and checked items are highlighted in the heatmap by a blue bar on the 

applicable axis. Items must be checked to be highlighted (gene group member highlighting illustrated). 

Also refer to Gene Highlighting. 

Highlighting on the y-axis (genes): 

• Individual genes are highlighted when a gene transcript is selected in the spatial view 

window. 

• Individual genes are highlighted when a gene is selected in the genes panel. 

• Gene group members are highlighted when a gene group is selected in the genes 

panel. 

• Individual genes are highlighted when a gene name (label) on the left side of the 

heatmap is selected. 

• Use Ctrl-click to select multiple genes. 

Highlighting on the x-axis (cells or ROIs): 

• Individual cells or ROIs are highlighted when a cell or ROI name (label) at the top of the 

heatmap is selected. Use Ctrl-click to select multiple individual cells or ROIs. The selected 

(and highlighted) cells or ROIs are listed in the selected items panel. 

• Individual cells or ROIs are also highlighted when a cell or ROI is selected in the spatial view 

window or scatterplot. 

• Cell or ROI group members are highlighted when selected in the spatial features panel, or in the 

spatial view window or scatterplot using the multi-feature selection tool. 

Cell/ROI names and gene names can be copied from heatmap axes by right-click on the name. 


